log in | register | forums
Show:
Go:
Forums
Username:

Password:

User accounts
Register new account
Forgot password
Forum stats
List of members
Search the forums

Advanced search
Recent discussions
- Gerph's live coding session on Youtube (News:1)
- Rougol June 2024 meeting on monday (News:1)
- WROCC June 2024 meeting - Mark Moxon dissects Lander (News:1)
- WROCC June 2024 meeting on wednesday - Mark Moxon on Lander (News:1)
- June developer 'fireside' chat is on saturday night (News:)
- May 2024 News Summary (News:5)
- Archive Edition 27:2 reviewed (News:)
- RISC OS 5.30 arrives (News:12)
- Rougol Talk May 2024 - Andy Vawer (News:)
- Rougol May 2024 meeting on monday with Andy Vawer (News:1)
Latest postings RSS Feeds
RSS 2.0 | 1.0 | 0.9
Atom 0.3
Misc RDF | CDF
 
View on Mastodon
@www.iconbar.com@rss-parrot.net
Site Search
 
Article archives
The Icon Bar: Games: !RiscTyrian, port of OpenTyrian
 
  !RiscTyrian, port of OpenTyrian
  franck (15:30 4/11/2012)
  swirlythingy (18:16 4/11/2012)
    franck (18:39 4/11/2012)
      swirlythingy (20:49 4/11/2012)
 
Franck Martinaux Message #121384, posted by franck at 15:30, 4/11/2012
Member
Posts: 25
Hi,

I made a version of OpenTyrian for RISC OS called !RiscTyrian
You can download it here :
http://www.norisc-nofun.co.uk/downloads/RiscTyrian_0.1.zip


Features :
- Home made RGB Scanline effect
- Play full speed on Beagleboard XM in 1280x800


Requirements :

RISC OS 5.18+
Armv6+ CPU (Raspberry Pi, Beagleboard, or Pandaboard)

Limitations and known issue :
- VERY SLOW on Raspberry Pi
- Your monitor needs to support a resolution of 1280x800
- Any other scaler than the one implemented is supported
- Support of config file removed.


Have Fun.
  ^[ Log in to reply ]
 
Martin Bazley Message #121387, posted by swirlythingy at 18:16, 4/11/2012, in reply to message #121384

Posts: 460
Is my ship supposed to keep drifting to the left like that? It makes flying really awkward.
  ^[ Log in to reply ]
 
Franck Martinaux Message #121388, posted by franck at 18:39, 4/11/2012, in reply to message #121387
Member
Posts: 25
Hi,

That is surely because the input settings is "mouse"
Try to play with your mouse or change the setup for keyboard.

Hope it helps
  ^[ Log in to reply ]
 
Martin Bazley Message #121390, posted by swirlythingy at 20:49, 4/11/2012, in reply to message #121388

Posts: 460
That is surely because the input settings is "mouse"
That's quite some achievement, given that the only two input settings I could find are "keyboard" and "joystick". How do I go about turning off this secret "mouse" option?
  ^[ Log in to reply ]
 

The Icon Bar: Games: !RiscTyrian, port of OpenTyrian